Displays with Android OS 4.4-6.0 having connection issues

Resolved
Minor outage
Started over 2 years ago Lasted about 7 hours

Affected

Displays
T1B - Meet-Work-Visit (Europe)
T2B - Meet-Work-Visit (Europe)
Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Monitoring
    Monitoring

    We implemented a fix and currently monitoring the result.

  • Identified
    Identified

    Due to upcoming changes in the root certification of the TLS certificates, the current certificates are cross-signed, to have proper support on older Android devices (4.4-6.0). Due to problems in the cross signing, only the new root CA was recognized, which is not trusted by the older Android devices (4.4-6.0).

  • Investigating
    Investigating

    We are currently investigating this incident.